2011.12.06 09:34

UTP(Unshilded Twisted Pair) Cable

흔히들 말하는 Lan선이라고 합니다


종류는 Straight, CrossOver, Rolled 로 나눠집니다.


Stright는 Direct 케이블이라고도 부릅니다.

다른장비의 다이렉트 로 외우면 편하십니다

케이블 선 외우는 순서로는

'주백 주 녹백 청 청백 녹 갈백 갈' 순으로 외우며

서로 다른 장비를 연결할 때 사용합니다.


CrossOver는 

케이블 선 외우는 순서로는

'녹백 녹 주백 청 청백 주 갈백 갈' 순으로 외워주며

서로 같은 장비를 연결할 때 사용합니다.



Rolled는 

PC와 Router Console 포트를 연결할때 사용하는 선으로

한쪽은 '주백 주 녹백 청 청백 녹 갈백 갈'

나머지 한쪽은 위의 방식을 반대로한 '갈 갈백 녹 청백 청 녹백 주 주백'으로

만들어주시면됩니다.


위와같이 서로 다른장비를 연결하는 Stright 케이블, 같은 장비를 연결하는 CrossOver으로써


L3 장비를 Router, PC

L2 장비를 Switch, Hub 로 생각하시면 쉽게 이해가됩니다.


Router < > Switch : Stright

Router < > Hub : Stright

Switch < > PC : Stright

Switch < > Router : Stright

PC < > Hub : Stright


PC < > PC : CrossOver

PC < > Router : CrossOver

Router < > Router : CrossOver

Switch < > Hub : CrossOver

Switch < > Switch : CrossOver

Hub < > Hub : CrossOver

Posted by 크레이지신 크레이지신
2011.11.16 09:40

L3 스위칭 기술 ( 서로다른 VLAN 간 통신)

L3 스위치는 레이어3계층에 속하는, 즉 라우터의 역할을 할 수 있는 스위치를 말하는 것입니다.

일반적으로 스위치 네트워크를 구성할 때, VLAN을 이용하여 구성합니다.

왜냐하면  네트워크가 확장에 따라 트래픽 증가와 보안상 문제 때문입니다

 

VLAN 끼리도 통신이 필요할 때가 있습니다 때문에 

L3 장비, 즉 라우터가 필요로 하게 됩니다~

라우터가 아니여도 L3 스위치를 이용하여 라우터의 역할을 대신할 수 있습니다


* SVI를 이용한 vlan간의 라우팅


vlan에 IP 주소를 넣기위해 "interface vlan"을 만들어야 하는데,

SVI(Switch Virtual Interface)라는 논리적인 인터페이스가 생성되어 IP 주소를 넣고 통신을 가능하도록 합니다.

설정해 볼까요~

 

[VLAN에 라우팅 설정하기]
Sw1(config)#ip routing

스위치에서 라우팅 기능을 이용한다는 의미로 위와 같이 명령어를 입력 해줘야 합니다.

Sw1(config)#vlan 10
Sw1(config)#vlan 20

 

Sw1(config)#int fa0/1
Sw1(config-if)#switchport mode access
Sw1(config-if)#switchport access vlan 10

 

Sw1(config)#int fa0/2
Sw1(config-if)#switchport mode access
Sw1(config-if)#switchport access vlan 20

 

Switch1(config)#int vlan 10
Switch1(config-if)#ip addr 10.10.10.254 255.255.255.0

 

Switch1(config)#int vlan 20
Switch1(config-if)#ip addr 10.10.20.254 255.255.255.0

통신이 되는지 확인해 봅시다

 [라우팅 확인하기]

P1#ping 10.10.20.1
 

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.20.1, timeout is 2 second:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms

 

vlan에 SVI를 만들어 IP 주소를 넣고 라우팅 시키는 방법은 위와 같구요~

 

이번에는 라우터를 이용해서 vlan간의 통신을 해볼까요~

 
2. 라우터를 이용한 vlan간의 라우팅

스위치와 연결되어 있는 부분은  트렁크 포트로 만들어 802.1q나 isl 모드로 바꿔야 하고,

다닐 수 있는 vlan의 설정을 해주어야 합니다.

 설정해 볼까요~

아 우선 주 인터페이스를 먼저 확인해서 정보를 먼저 봐야 겠져~ 

[이더넷을 서브 인터페이스로 나누기]
Router1(config)#int fa0/0
Router1(config-if)#no shutdown

주 인터페이스에 들어가 우선 인터페이스를 UP 시켜주세요~

Router1(config)#int fa0/0.10
Router1(config-if)#encapsulation dot1q 10
Router1(config-if)#ip addr 10.10.10.254 255.255.255.0

 

Router1(config)#int fa0/0.20
Router1(config-if)#encapsulation dot1q 20
Router1(config-if)#ip addr 10.10.20.254 255.255.255.0

 

시리얼 서브 잡는것과 마찬가지로 fa0/0.xx 이렇게 해주면 됩니다

편의상 흘러다니는 vlan의 번호로 
지정해주었습니다.

IP 주소를 넣고 802.1x 방식으로 트렁크 모드로 만듭니다

[스위치 설정하기]

Sw(config)#int fa0/1
Sw(config-if)#switchport mode access
Sw(config-if)#switchport access vlan 10

 

Sw(config)#int fa0/2
Sw(config-if)#switchport mode access
Sw(config-if)#switchport access vlan 20

 

Sw(config)#int fa0/10
Sw(config-if)#switchport trunk encapsulation dot1q
Sw(config-if)#switchport mode trunk
Sw(config-if)#switchport trunk allowed vlan 10,20

 

fa0/10 포트를 트렁크로 만들고 흘러다닐 수 있는 vlan을 10,20으로 지정해 주었습니다.

 

[라우팅 확인하기]
P1#ping 10.10.20.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.20.1, timeout is 2 second:
!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms

 
Posted by 크레이지신 크레이지신
2011.11.07 23:38
RHCE Exam 준비가이드
http://www.kr.redhat.com/training/rhce_pre_guide.html
1. 디스크 파티션 이해 및 Red Hat Linux 설치시 파티션 툴의 사용 방법
2. Red Hat Linux 설치에 관한 전반적인 이해 및 능력, 특히 네트워크 설치
3. 설치시 구성 요소에 관한 이해 (LILO/GRUB, authentication, networking, system initialization, packages 등)
4. 설치 옵션의 post-installation 구성 방법에 관한 이해
5. Red Hat Linux 파일시스템 레이아웃 이해
6. script가 하는 일 및 /etc/sysconfig/network-scripts 파일 구성에 대한 이해
7. multiple-boot 설치에의 다양한 접근 방법 이해 및 때때로 multiple-boot 설치에 사용되는 관련 설치 툴(rawrite, fips)
8. kickstart 설치 기본 이해 (kickstart file, floppy- vs. network-based, installation media, boot disk preparation, etc.)
9. rpm 명령어 및 switch들에 대한 전반적인 지식, 특히 설치 및 querying of package에 관계된 것.
10. 기본적인 source(*.src.rpm) rpm packages 요소에 대한 이해
11. system recovery를 위한 rescue 환경으로의 부팅 방법 및 사용법
12. 여러 종류의 user account 생성법
13. user 환경 구성법
14. system and user bash configuration files
15. quotas, quota concepts 이해 및 user, group quotas 방법
16. cron system 이해 및 cron을 사용해서 scheduled jobs를 셋팅하는 방법
17. 필수 커널 개념 이해 (monolithic vs. modular kernels, initial ramdisks, etc)
18. 커널 소스 설치 및 Linux 커널을 rebuild하기 위해 필요한 개발 툴
19. 소스로 부터 Linux 커널과 모듈을 구성, build, 설치하는 법. LILO/ GRUB 요소, 부팅 절차 및 구성에 대한 이해
20. Apache, Samba, NFS, basic sendmail, POP3/IMAP4 email, DNS, and ftp 등 network services에 대한 이해
21. 기본적인 troubleshooting을 할 수 있도록 그런 서비스의 function, configuration, logging에 대한 충분한 이해 필요
22. 위의 서비스를 위한 access 제한 방법
23. Red Hat Linux에서 지원되는 다른 network services : squid, innd NNTP server, xntpd, etc.
24. 일반적인 X 이해 및 특히 XFree86 X server에 대한 이해. (configuration file 및 그 파일을 수정하는데 사용되는 툴 포함)
25. Red Hat Linux 상에서 가능한 윈도우 매니저와 데스크탑 환경 선택 및 방법 이해
26. remote login과 remote client를 포함한 remote로 X 사용하기
27. xinetd 역할 이해 및 tcp_wrappers 보안 방법의 실행법 이해
28. 기본적인 NIS 개념 이해 및 NIS와 관련된 components.
29. PAM subsystem의 목적 이해, 기본적인 PAM 구성 변경법
30. router로서의 Red Hat Linux 사용과 관련된 configuration issues : routing options, IP forwarding, and kernel configuration
31. 기본적인 firewall 정책을 실행하기 위해 iptables 사용하기, Red Hat Linux에서의 User Private Group scheme 이해

본자료는 KLDP 에서 참조해서 퍼온글 입니다 정보공유의 목적으로만 링크했으니 문제가 된다면 삭제하겠습니다 ^^;; 
Posted by 크레이지신 크레이지신